SPH Water Simulatio...
 

SPH Water Simulation in LS-DYNA (Urgent!)  

 

adityasreekumar
(@adityasreekumar)
Active Member
Joined: 2 months ago
Posts: 5
October 23, 2019 3:35 pm  

Sorry my last post didn't get posted correctly! My bad!

Now, I am trying to simulate a floating body on SPH water particles.

The unit system used is m kg sec Pa J and its consistent, the density of the rigid body is far less than water and it should float which isn't happening. It will contact with the water violently or no contact will occur. I am using EOS_MURNAGHAN(Data taken from LSTC official website and other references) and MAT_NULL for modelling water. And the FEM wedge is shell meshed with thickness in mm. I am using Automatic_Nodes_Surface contact. 

I have attached the k file with this post and a DRIVE LINK with the output video and K files.

1) No contact case 2) Violent contact case. 

 

DRIVE LINK-

https://drive.google.com/open?id=1fKbyHx7i7GS650kT_9r715XfmKTFHsRC

Please help me out. Thanks!


Quote
Negative Volume
(@negativevolume)
Estimable Member Admin
Joined: 10 months ago
Posts: 120
October 24, 2019 4:52 pm  

Hi @adityasreekumar

Which file corresponds to your no contact case and violent case? There are two files (LesserDensity_64000.k) (Wedge.k). Also what version of LS-Dyna are you running?


ReplyQuote
adityasreekumar
(@adityasreekumar)
Active Member
Joined: 2 months ago
Posts: 5
October 24, 2019 5:11 pm  

@negativevolume

Hi!

Thanks a lot for checking out the files. I've put the video output along with file.

*LesserDensity_64000 is where contact is NOT happening. While the wedge zip file contains the file where contact is happening vigorously.

 

Some of the things I wish to explain -

I've used both the EOS - Gruinessen as well as Murnaghan (Taits equation), I've also tried with different mesh sizes of the wedge and also have checked if the normals of the shell elements are pointing to outwards. 

I've done Dam Break and many other problems (like a drop of SPH water falling onto a plate) with Automatic Nodes to surface which works. I've also tried the SOFT=1 option and have changed the shell element thickness too. So please do let me know what else may be causing this problem?. You can just run the case too. Thanks a lot.


ReplyQuote
Negative Volume
(@negativevolume)
Estimable Member Admin
Joined: 10 months ago
Posts: 120
October 30, 2019 12:54 pm  

@adityasreekumar

Sorry I haven't had a ton of time to look through your sim. You mentioned that this was Urgent, did you ever figure this out or are you still working on it?


ReplyQuote
Share: